openSUSE Security Update : w3m (openSUSE-SU-2010:0393-1)

Medium Nessus Plugin ID 47777


The remote openSUSE host is missing a security update.


w3m did not handle embedded nul characters in the common name and in subject alternative names of x509 certificates. CVE-2010-2074 has been assigned to this issue. This update also turns on verification of x509 certificates by default which was not the case before.


Update the affected w3m packages.

See Also

Plugin Details

Severity: Medium

ID: 47777

File Name: suse_11_2_w3m-100616.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2010/07/21

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:w3m, p-cpe:/a:novell:opensuse:w3m-inline-image, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/06/16

Reference Information

CVE: CVE-2010-2074