MySQL Community Server < 5.1.48 Denial of Service

Low Nessus Plugin ID 47158


The remote database server is affected by denial of service vulnerability.


The version of MySQL Community Server installed on the remote host is earlier than 5.1.48 and thus potentially affected by a denial of service vulnerability.

The 'ALTER DATABASE' command can be misused by a user with 'ALTER' permissions to cause the MySQL data directory to become unusable.


Upgrade to MySQL Community Server 5.1.48 or later.

See Also

Plugin Details

Severity: Low

ID: 47158

File Name: mysql_5_1_48.nasl

Version: 1.12

Type: remote

Family: Databases

Published: 2010/06/29

Updated: 2018/11/15

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 3.5

Temporal Score: 2.7

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/06/02

Vulnerability Publication Date: 2010/06/02

Reference Information

CVE: CVE-2010-2008

BID: 41198

Secunia: 40333