MySQL Community Server < 5.1.48 Denial of Service

low Nessus Plugin ID 47158
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by denial of service vulnerability.

Description

The version of MySQL Community Server installed on the remote host is earlier than 5.1.48 and thus potentially affected by a denial of service vulnerability.

The 'ALTER DATABASE' command can be misused by a user with 'ALTER' permissions to cause the MySQL data directory to become unusable.

Solution

Upgrade to MySQL Community Server 5.1.48 or later.

See Also

https://bugs.mysql.com/bug.php?id=53804

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-48.html

Plugin Details

Severity: Low

ID: 47158

File Name: mysql_5_1_48.nasl

Version: 1.12

Type: remote

Family: Databases

Published: 6/29/2010

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.7

Vector: AV:N/AC:M/Au:S/C:N/I:N/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/2/2010

Vulnerability Publication Date: 6/2/2010

Reference Information

CVE: CVE-2010-2008

BID: 41198

Secunia: 40333