openSUSE Security Update : aria2 (openSUSE-SU-2010:0338-1)

Medium Nessus Plugin ID 47134


The remote openSUSE host is missing a security update.


This aria2 update to 1.9.3 fixes a metalink name Directory Traversal issue (CVE-2010-1512).

The version was also bumped from 1.8.2 to 1.9.3 to fix lots of bugs.


Update the affected aria2 package.

See Also

Plugin Details

Severity: Medium

ID: 47134

File Name: suse_11_2_aria2-100604.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2010/06/25

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:aria2, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/06/04

Reference Information

CVE: CVE-2010-1512