Apache Tomcat 5.x < 5.5.21 Multiple Vulnerabilities

Medium Nessus Plugin ID 46868


The remote web server is affected by multiple vulnerabilities.


According to its self-reported version number, the instance of Apache Tomcat 5.x listening on the remote host is prior to 5.5.21. It is, therefore, affected by the following vulnerabilities :

- The remote Apache Tomcat install is vulnerable to a cross-site scripting attack. The client supplied Accept-Language headers are not validated which allows an attacker to use a specially crafted URL to inject arbitrary HTML and script code into the user's browser.

- If the remote Apache Tomcat install is configured to use the SingleSignOn Valve, the JSESSIONIDSSO cookie does not have the 'secure' attribute set if authentication takes place over HTTPS. This allows the JSESSIONIDSSO cookie to be sent to the same server when HTTP content is requested. (CVE-2008-0128)

- The remote Apache Tomcat install is affected by an information disclosure vulnerability. The doRead method fails to return the proper error code for certain error conditions, which can cause POST content to be sent to different, and improper, requests. (CVE-2008-4308)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 5.5.21 or later.

See Also



Plugin Details

Severity: Medium

ID: 46868

File Name: tomcat_5_5_21.nasl

Version: $Revision: 1.17 $

Type: remote

Family: Web Servers

Published: 2010/06/11

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:ND/RC:C


Base Score: 5.3

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:X/RL:X/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2007/02/06

Vulnerability Publication Date: 2007/02/05

Reference Information

CVE: CVE-2007-1358, CVE-2008-0128, CVE-2008-4308

BID: 24524, 27365, 33913

OSVDB: 34881, 40853, 52407

Secunia: 28552, 34057

CWE: 16, 79, 200