CVE-2007-1358

LOW

Description

Cross-site scripting (XSS) vulnerability in certain applications using Apache Tomcat 4.0.0 through 4.0.6 and 4.1.0 through 4.1.34 allows remote attackers to inject arbitrary web script or HTML via crafted "Accept-Language headers that do not conform to RFC 2616".

References

http://community.ca.com/blogs/casecurityresponseblog/archive/2009/01/23.aspx

http://docs.info.apple.com/article.html?artnum=306172

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01178795

http://jvn.jp/jp/JVN%2316535199/index.html

http://lists.apple.com/archives/security-announce//2007/Jul/msg00004.html

http://osvdb.org/34881

http://rhn.redhat.com/errata/RHSA-2008-0630.html

http://secunia.com/advisories/25721

http://secunia.com/advisories/26235

http://secunia.com/advisories/26660

http://secunia.com/advisories/27037

http://secunia.com/advisories/27727

http://secunia.com/advisories/30899

http://secunia.com/advisories/30908

http://secunia.com/advisories/31493

http://secunia.com/advisories/33668

http://sunsolve.sun.com/search/document.do?assetkey=1-26-239312-1

http://support.ca.com/irj/portal/anonymous/phpsupcontent?contentID=197540

http://tomcat.apache.org/security-4.html

http://www.fujitsu.com/global/support/software/security/products-f/interstage-200704e.html

http://www.redhat.com/support/errata/RHSA-2008-0261.html

http://www.securityfocus.com/archive/1/471719/100/0/threaded

http://www.securityfocus.com/archive/1/500396/100/0/threaded

http://www.securityfocus.com/archive/1/500412/100/0/threaded

http://www.securityfocus.com/bid/24524

http://www.securityfocus.com/bid/25159

http://www.securitytracker.com/id?1018269

http://www.vupen.com/english/advisories/2007/1729

http://www.vupen.com/english/advisories/2007/2732

http://www.vupen.com/english/advisories/2007/3087

http://www.vupen.com/english/advisories/2007/3386

http://www.vupen.com/english/advisories/2008/1979/references

http://www.vupen.com/english/advisories/2009/0233

https://lists.apache.org/thread.html/[email protected]%3Cdev.tomcat.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Cdev.tomcat.apache.org%3E

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10679

https://www.redhat.com/archives/fedora-package-announce/2007-November/msg00525.html

Details

Source: MITRE

Published: 2007-05-10

Updated: 2019-03-25

Type: CWE-79

Risk Information

CVSS v2.0

Base Score: 2.6

Vector: AV:N/AC:H/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 4.9

Severity: LOW