Debian DSA-2048-1 : dvipng - buffer overflow

Medium Nessus Plugin ID 46707

Synopsis

The remote Debian host is missing a security-related update.

Description

Dan Rosenberg discovered that in dvipng, a utility that converts DVI files to PNG graphics, several array index errors allow context-dependent attackers, via a specially crafted DVI file, to cause a denial of service (crash of the application), and possibly arbitrary code execution.

Solution

Upgrade the dvipng package.

For the stable distribution (lenny), this problem has been fixed in version dvipng_1.11-1+lenny1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=580628

https://www.debian.org/security/2010/dsa-2048

Plugin Details

Severity: Medium

ID: 46707

File Name: debian_DSA-2048.nasl

Version: 1.8

Type: local

Agent: unix

Published: 2010/05/25

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:dvipng, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/05/22

Reference Information

CVE: CVE-2010-0829

BID: 39969

DSA: 2048