CVE-2010-0829

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Multiple array index errors in set.c in dvipng 1.11 and 1.12, and teTeX, allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a malformed DVI file.

References

http://lists.fedoraproject.org/pipermail/package-announce/2010-May/041587.html

http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00002.html

http://lists.opensuse.org/opensuse-security-announce/2010-06/msg00001.html

http://secunia.com/advisories/39914

http://www.debian.org/security/2010/dsa-2048

http://www.ubuntu.com/usn/USN-936-1

http://www.vupen.com/english/advisories/2010/1219

https://bugzilla.redhat.com/show_bug.cgi?id=573999

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9718

Details

Source: MITRE

Published: 2010-05-07

Updated: 2017-09-19

Type: CWE-119

Risk Information

CVSS v2

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (16 total)

IDNameProductFamilySeverity
79961GLSA-201412-08 : Multiple packages, Multiple vulnerabilities fixed in 2010NessusGentoo Local Security Checks
critical
68039Oracle Linux 5 : tetex (ELSA-2010-0400)NessusOracle Linux Local Security Checks
high
60791Scientific Linux Security Update : tetex on SL5.x i386/x86_64NessusScientific Linux Local Security Checks
high
51761SuSE 10 Security Update : TeX (ZYPP Patch Number 7020)NessusSuSE Local Security Checks
medium
50963SuSE 11 Security Update : TeX (SAT Patch Number 2393)NessusSuSE Local Security Checks
medium
47486Fedora 13 : dvipng-1.13-1.fc13 (2010-8335)NessusFedora Local Security Checks
medium
47483Fedora 11 : dvipng-1.13-1.fc11 (2010-8279)NessusFedora Local Security Checks
medium
47480Fedora 12 : dvipng-1.13-1.fc12 (2010-8252)NessusFedora Local Security Checks
medium
46760CentOS 5 : tetex (CESA-2010:0400)NessusCentOS Local Security Checks
high
46707Debian DSA-2048-1 : dvipng - buffer overflowNessusDebian Local Security Checks
medium
46344openSUSE Security Update : texlive (openSUSE-SU-2010:0251-1)NessusSuSE Local Security Checks
medium
46342openSUSE Security Update : texlive (openSUSE-SU-2010:0251-1)NessusSuSE Local Security Checks
medium
46340openSUSE Security Update : texlive (openSUSE-SU-2010:0251-1)NessusSuSE Local Security Checks
medium
46330Mandriva Linux Security Advisory : tetex (MDVSA-2010:094)NessusMandriva Local Security Checks
high
46309RHEL 5 : tetex (RHSA-2010:0400)NessusRed Hat Local Security Checks
high
46253Ubuntu 9.04 / 9.10 / 10.04 LTS : dvipng vulnerability (USN-936-1)NessusUbuntu Local Security Checks
medium