openSUSE Security Update : ncpfs (openSUSE-SU-2010:0264-1)

Medium Nessus Plugin ID 46670


The remote openSUSE host is missing a security update.


This update fixes three security issues in ncpfs :

Fixed a information leakage on mount (CVE-2010-0790 / bnc#583536) Fixed a mtab locking problem (CVE-2010-0791 / bnc#583536) Fixed a race condition in ncpfs mounts (CVE-2010-0788 / bnc#550004)


Update the affected ncpfs packages.

See Also

Plugin Details

Severity: Medium

ID: 46670

File Name: suse_11_1_ncpfs-100504.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2010/05/19

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ncpfs, p-cpe:/a:novell:opensuse:ncpfs-32bit, p-cpe:/a:novell:opensuse:ncpfs-devel, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/05/04

Reference Information

CVE: CVE-2010-0788, CVE-2010-0790, CVE-2010-0791

CWE: 59, 200, 264