MySQL Community Server 5.1 < 5.1.46 Multiple Vulnerabilities

low Nessus Plugin ID 46328
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote database server is affected by multiple vulnerabilities.


The version of MySQL Community Server 5.1 installed on the remote host is earlier than 5.1.46 and thus potentially affected by the following vulnerabilities :

- A local user may be able to issue a 'DROP TABLE' command for one MyISAM table and remove the data and index files of a different MyISAM table. (Bug #40980)

- The application does not correct check privileges in calls to 'UNINSTALL PLUGIN', which could be abused by an unprivileged user to uninstall plugins loaded dynamically. (Bug #51770)


Upgrade to MySQL Community Server 5.1.46 or later.

See Also

Plugin Details

Severity: Low

ID: 46328

File Name: mysql_5_1_46.nasl

Version: 1.13

Type: remote

Family: Databases

Published: 5/12/2010

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Low

Score: 3.4


Risk Factor: Low

Base Score: 3.6

Temporal Score: 2.7

Vector: AV:N/AC:H/Au:S/C:N/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/6/2010

Vulnerability Publication Date: 3/9/2010

Reference Information

CVE: CVE-2010-1621, CVE-2010-1626

BID: 39543, 40257