openSUSE Security Update : libesmtp (openSUSE-SU-2010:0220-1)

Medium Nessus Plugin ID 46250


The remote openSUSE host is missing a security update.


libesmtp did not properly handle wildcards and embedded null characters in the Common Name of X.509 certificates (CVE-2010-1192, CVE-2010-1194).


Update the affected libesmtp packages.

See Also

Plugin Details

Severity: Medium

ID: 46250

File Name: suse_11_1_libesmtp-100430.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2010/05/07

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libesmtp, p-cpe:/a:novell:opensuse:libesmtp-devel, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/04/30

Reference Information

CVE: CVE-2010-1192, CVE-2010-1194