openSUSE Security Update : libmysqlclient-devel (openSUSE-SU-2010:0198-2)

Medium Nessus Plugin ID 46229

Synopsis

The remote openSUSE host is missing a security update.

Description

Updated mysql packages fix the following bugs :

- upstream #47320 - checking server certificates (CVE-2009-4028)

- upstream #48291 - error handling in subqueries (CVE-2009-4019)

- upstream #47780 - preserving null_value flag in GeomFromWKB() (CVE-2009-4019)

- upstream #39277 - symlink behaviour fixed (CVE-2008-7247)

- upstream #32167 - symlink behaviour refixed (CVE-2009-4030)

Solution

Update the affected libmysqlclient-devel packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=557669

https://lists.opensuse.org/opensuse-updates/2010-05/msg00006.html

Plugin Details

Severity: Medium

ID: 46229

File Name: suse_11_0_libmysqlclient-devel-100504.nasl

Version: 1.8

Type: local

Agent: unix

Published: 2010/05/05

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libmysqlclient-devel, p-cpe:/a:novell:opensuse:libmysqlclient15, p-cpe:/a:novell:opensuse:libmysqlclient15-32bit, p-cpe:/a:novell:opensuse:libmysqlclient_r15, p-cpe:/a:novell:opensuse:libmysqlclient_r15-32bit, p-cpe:/a:novell:opensuse:mysql, p-cpe:/a:novell:opensuse:mysql-Max, p-cpe:/a:novell:opensuse:mysql-bench, p-cpe:/a:novell:opensuse:mysql-client, p-cpe:/a:novell:opensuse:mysql-debug, p-cpe:/a:novell:opensuse:mysql-tools, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/05/04

Reference Information

CVE: CVE-2008-7247, CVE-2009-4019, CVE-2009-4028, CVE-2009-4030

CWE: 20, 59