SuSE 10 Security Update : Apache 2 (ZYPP Patch Number 6984)

Medium Nessus Plugin ID 46013


The remote SuSE 10 host is missing a security-related patch.


The following bugs have been fixed :

When using a multi-threaded MPM apache could leak memory of requests handled by a different thread when processing subrequests (CVE-2010-0434). Specially crafted requests could crash mod_proxy_ajp.


Apply ZYPP patch number 6984.

See Also

Plugin Details

Severity: Medium

ID: 46013

File Name: suse_apache2-6984.nasl

Version: $Revision: 1.13 $

Type: local

Agent: unix

Published: 2010/04/27

Modified: 2013/07/20

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2010/04/13

Reference Information

CVE: CVE-2010-0408, CVE-2010-0434

CWE: 200