openSUSE Security Update : systemtap (openSUSE-SU-2010:0166-1)

Critical Nessus Plugin ID 46012


The remote openSUSE host is missing a security update.


This updates systemtap to version 1.0. The version update was required to fix two issues; a shell meta.character injection vulnerability that allowed remote users to execute arbitrary commands () with the privileges of the stap-server. (CVE-2009-4273: CVSS v2 Base Score: 7.9 (important) (AV:A/AC:M/Au:N/C:C/I:C/A:C)) and a remote denial of service bug in the __get_argv() function (CVE-2010-0411: CVSS v2 Base Score: 4.9 (MEDIUM) (AV:L/AC:L/Au:N/C:N/I:N/A:C)). Version 1.0 is also subject to advisory CVE-2009-2911 fixing three denial of service issues when using unprivileged mode.


Update the affected systemtap packages.

See Also

Plugin Details

Severity: Critical

ID: 46012

File Name: suse_11_2_systemtap-100301.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2010/04/27

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:systemtap, p-cpe:/a:novell:opensuse:systemtap-client, p-cpe:/a:novell:opensuse:systemtap-runtime, p-cpe:/a:novell:opensuse:systemtap-sdt-devel, p-cpe:/a:novell:opensuse:systemtap-server, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/03/01

Reference Information

CVE: CVE-2009-2911, CVE-2009-4273, CVE-2010-0411

CWE: 94, 189, 264