openSUSE Security Update : gimp (openSUSE-SU-2010:0115-1)

High Nessus Plugin ID 45537


The remote openSUSE host is missing a security update.


Integer overflows in the BMP and PSD plug-ins potentially allowed attackers to execute arbitrary code on the victim's system by tricking the victim to open specially crafted files (CVE-2009-1570, CVE-2009-3909).

Gimp was updated to to version 2.6.8 which fixes those issues.


Update the affected gimp packages.

See Also

Plugin Details

Severity: High

ID: 45537

File Name: suse_11_2_gimp-100318.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2010/04/15

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gimp, p-cpe:/a:novell:opensuse:gimp-branding-upstream, p-cpe:/a:novell:opensuse:gimp-devel, p-cpe:/a:novell:opensuse:gimp-help-browser, p-cpe:/a:novell:opensuse:gimp-lang, p-cpe:/a:novell:opensuse:gimp-plugins-python, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/03/18

Reference Information

CVE: CVE-2009-1570, CVE-2009-3909

CWE: 189