Adobe Reader < 9.3.2 / 8.2.2 Multiple Vulnerabilities (APSB10-09)

high Nessus Plugin ID 45505

Language:

Synopsis

The version of Adobe Reader on the remote Windows host is affected by multiple vulnerabilities.

Description

The version of Adobe Reader installed on the remote host is earlier than 9.3.2 / 8.2.2. Such versions are reportedly affected by multiple vulnerabilities :
- A cross-site scripting issue could lead to code execution. (CVE-2010-0190)

- A prefix protocol handler vulnerability could lead to code execution. (CVE-2010-0191)

- A denial of service vulnerability could potentially lead to code execution. (CVE-2010-0192)

- A denial of service vulnerability could potentially lead to code execution. (CVE-2010-0193)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-0194)

- A font handling vulnerability could lead to code execution. (CVE-2010-0195)

- A denial of service vulnerability could potentially lead lead to code execution. (CVE-2010-0196)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-0197)

- A buffer overflow vulnerability could lead to code execution. (CVE-2010-0198)

- A buffer overflow vulnerability could lead to code execution. (CVE-2010-0199)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-0201)

- A buffer overflow vulnerability could lead to code execution. (CVE-2010-0202)

- A buffer overflow vulnerability could lead to code execution. (CVE-2010-0203)

- A memory corruption vulnerability could lead to code execution. (CVE-2010-0204)

- A heap-based buffer overflow vulnerability could lead to code execution. (CVE-2010-1241)

Solution

Upgrade to Adobe Reader 9.3.2 / 8.2.2 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb10-09.html

Plugin Details

Severity: High

ID: 45505

File Name: adobe_reader_apsb10-09.nasl

Version: 1.20

Type: local

Agent: windows

Family: Windows

Published: 4/13/2010

Updated: 6/27/2018

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 8.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Acroread/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/13/2010

Vulnerability Publication Date: 4/13/2010

Reference Information

CVE: CVE-2010-0190, CVE-2010-0191, CVE-2010-0192, CVE-2010-0193, CVE-2010-0194, CVE-2010-0195, CVE-2010-0196, CVE-2010-0197, CVE-2010-0198, CVE-2010-0199, CVE-2010-0201, CVE-2010-0202, CVE-2010-0203, CVE-2010-0204, CVE-2010-1241

BID: 39227, 39417, 39469, 39470, 39505, 39507, 39511, 39514, 39515, 39517, 39518, 39520, 39521, 39522, 39523, 39524