openSUSE Security Update : libtheora (libtheora-2069)

High Nessus Plugin ID 45455


The remote openSUSE host is missing a security update.


An integer overflow was fixed in libtheora. It could be exploited remotely to execute arbitrary code. CVE-2009-3389: CVSS v2 Base Score:
9.3 (HIGH) (AV:N/AC:M/Au:N/C:C/I:C/A:C): Numeric Errors (CWE-189)


Update the affected libtheora packages.

See Also

Plugin Details

Severity: High

ID: 45455

File Name: suse_11_0_libtheora-100224.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2010/04/09

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libtheora-devel, p-cpe:/a:novell:opensuse:libtheora0, p-cpe:/a:novell:opensuse:libtheora0-32bit, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/02/24

Reference Information

CVE: CVE-2009-3389

CWE: 189