FreeBSD : dojo -- XSS and other vulnerabilities (805603a1-3e7a-11df-a5a1-0050568452ac)

High Nessus Plugin ID 45446


The remote FreeBSD host is missing a security-related update.


The Dojo Toolkit team reports :

Some PHP files did not properly escape input.

Some files could operate like 'open redirects'. A bad actor could form an URL that looks like it came from a trusted site, but the user would be redirected or load content from the bad actor's site.

A file exposed a more serious cross-site scripting vulnerability with the possibility of executing code on the domain where the file exists.

The Dojo build process defaulted to copying over tests and demos, which are normally not needed and just increased the number of files that could be targets of attacks.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 45446

File Name: freebsd_pkg_805603a13e7a11dfa5a10050568452ac.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2010/04/09

Modified: 2014/08/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:dojo, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2010/04/06

Vulnerability Publication Date: 2010/03/11

Reference Information

Secunia: 38964