Foxit Reader < 3.2.1 Arbitrary Program Execution

High Nessus Plugin ID 45404


A PDF viewer installed on the remote host is affected by a command execution vulnerability.


The version of Foxit Reader installed on the remote Windows host is prior to 3.2.1. It is, therefore, affected by an arbitrary program execution vulnerability related to certain '/Type /Action /S /Launch' or '/Launch /Action' sequences. An attacker can exploit these, by tricking a user into opening a crafted PDF file, to cause arbitrary programs to be executed without user permission.


Upgrade to Foxit Reader version or later.

See Also

Plugin Details

Severity: High

ID: 45404

File Name: foxit_reader_3_2_1.nasl

Version: $Revision: 1.11 $

Type: local

Agent: windows

Family: Windows

Published: 2010/04/02

Modified: 2016/03/07

Dependencies: 32395

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:foxitsoftware:foxit_reader

Required KB Items: installed_sw/Foxit Reader

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/04/01

Vulnerability Publication Date: 2010/04/02

Reference Information

CVE: CVE-2010-1239

BID: 39109

OSVDB: 63548

Secunia: 39291

CERT: 570177

EDB-ID: 11987