openSUSE Security Update : viewvc (viewvc-2147)

Medium Nessus Plugin ID 45355


The remote openSUSE host is missing a security update.


Query forms didn't escape user provided input, therefore allowing cross-site-scripting (XSS) attacks. CVE-2010-0736 has been assigned to this issue.


Update the affected viewvc package.

See Also

Plugin Details

Severity: Medium

ID: 45355

File Name: suse_11_2_viewvc-100318.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2010/03/26

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:viewvc, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2010/03/18

Reference Information

CVE: CVE-2010-0736