openSUSE Security Update : cron (cron-2026)

Low Nessus Plugin ID 45098


The remote openSUSE host is missing a security update.


This update of cron fixes a race condition in crontab that can be used to change the time-stamp of arbitrary files while editing the crontab entry. CVE-2010-0424: CVSS v2 Base Score: 3.6 Additionally the return value of initgroups() is verified now.


Update the affected cron package.

See Also

Plugin Details

Severity: Low

ID: 45098

File Name: suse_11_1_cron-100219.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2010/03/19

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 3.3

Vector: CVSS2#AV:L/AC:M/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cron, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/02/19

Reference Information

CVE: CVE-2010-0424

CWE: 59