openSUSE Security Update : wireshark (wireshark-1900)

High Nessus Plugin ID 45074


The remote openSUSE host is missing a security update.


This update of wireshark fixes :

- CVE-2009-4376: Remote attackers could potentially trigger a buffer overflow in the Daintree SNA file parser.

- CVE-2009-4377: Specially crafted packets could cause the SMB and SMB2 dissector to crash wireshark.

- CVE-2009-2563: Unspecified vulnerability in the Infiniband dissector allows remote attackers to cause a denial of service.

- CVE-2010-0304: Several buffer overflows in the LWRES dissector.


Update the affected wireshark packages.

See Also

Plugin Details

Severity: High

ID: 45074

File Name: suse_11_1_wireshark-100203.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2010/03/17

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:wireshark, p-cpe:/a:novell:opensuse:wireshark-devel, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/02/03

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (Wireshark LWRES Dissector getaddrsbyname_request Buffer Overflow (loop))

Reference Information

CVE: CVE-2009-2563, CVE-2009-4376, CVE-2009-4377, CVE-2010-0304

CWE: 119