openSUSE Security Update : OpenOffice_org-base-drivers-postgresql (OpenOffice_org-base-drivers-postgresql-1981)

high Nessus Plugin ID 45073

Language:

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 8.4

Synopsis

The remote openSUSE host is missing a security update.

Description

This update of OpenOffice_org includes fixes for the following vulnerabilities :

- CVE-2009-0217: XML signature weakness

- CVE-2009-2949: XPM Import Integer Overflow

- CVE-2009-2950: GIF Import Heap Overflow

- CVE-2009-3301: MS Word sprmTDefTable Memory Corruption

- CVE-2009-3302: MS Word sprmTDefTable Memory Corruption

- CVE-2010-0136: In the ooo-build variant of OpenOffice_org VBA Macro support does not honor Macro security settings.

Solution

Update the affected OpenOffice_org-base-drivers-postgresql packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=521564

https://bugzilla.novell.com/show_bug.cgi?id=564497

https://bugzilla.novell.com/show_bug.cgi?id=564503

https://bugzilla.novell.com/show_bug.cgi?id=566030

Plugin Details

Severity: High

ID: 45073

File Name: suse_11_1_OpenOffice_org-base-drivers-postgresql-100211.nasl

Version: 1.12

Type: local

Agent: unix

Published: 3/17/2010

Updated: 1/14/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: High

VPR Score: 8.4

CVSS v2.0

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:OpenOffice_org-base-drivers-postgresql, p-cpe:/a:novell:opensuse:OpenOffice_org-gnome, p-cpe:/a:novell:opensuse:OpenOffice_org-kde, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-core, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-core-devel, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-core-l10n-prebuilt, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-extern, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-extern-devel, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-extern-l10n-prebuilt, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-gui, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-gui-devel, p-cpe:/a:novell:opensuse:OpenOffice_org-libs-gui-l10n-prebuilt, p-cpe:/a:novell:opensuse:OpenOffice_org-mailmerge, p-cpe:/a:novell:opensuse:OpenOffice_org-math, p-cpe:/a:novell:opensuse:OpenOffice_org-writer, p-cpe:/a:novell:opensuse:OpenOffice_org-writer-devel, p-cpe:/a:novell:opensuse:OpenOffice_org-writer-l10n-prebuilt, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/11/2010

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-0217, CVE-2009-2949, CVE-2009-2950, CVE-2009-3301, CVE-2009-3302, CVE-2010-0136

CWE: 94, 119, 189