openSUSE Security Update : libnetpbm-devel (libnetpbm-devel-2011)

High Nessus Plugin ID 44999


The remote openSUSE host is missing a security update.


This update of netpbm fxes a stack-based buffer overflow that could be triggered while processing the contents of XPM headers in image files.
(CVE-2009-4274: CVSS v2 Base Score: 5.8 (moderate) (AV:N/AC:M/Au:N/C:N/I:P/A:P): Buffer Errors (CWE-119))


Update the affected libnetpbm-devel packages.

See Also

Plugin Details

Severity: High

ID: 44999

File Name: suse_11_0_libnetpbm-devel-100216.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2010/03/08

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libnetpbm-devel, p-cpe:/a:novell:opensuse:libnetpbm10, p-cpe:/a:novell:opensuse:libnetpbm10-32bit, p-cpe:/a:novell:opensuse:netpbm, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/02/16

Reference Information

CVE: CVE-2009-4274

CWE: 119