openSUSE Security Update : finch (finch-2032)

Medium Nessus Plugin ID 44982


The remote openSUSE host is missing a security update.


This update of pidgin fixes various security vulnerabilities

- CVE-2010-0013: CVSS v2 Base Score: 4.3: Path Traversal (CWE-22) Remote file disclosure vulnerability by using the MSN protocol.

- CVE-2010-0277: CVSS v2 Base Score: 4.9: Resource Management Errors (CWE-399) MSN protocol plugin in libpurple allowed remote attackers to cause a denial of service (memory corruption) at least.

- CVE-2010-0420 Same nick names in XMPP MUC lead to a crash in finch.

- CVE-2010-0423 A remote denial of service attack (resource consumption) is possible by sending an IM with a lot of smilies in it.


Update the affected finch packages.

See Also

Plugin Details

Severity: Medium

ID: 44982

File Name: suse_11_2_finch-100219.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2010/03/04

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:finch, p-cpe:/a:novell:opensuse:finch-devel, p-cpe:/a:novell:opensuse:libpurple, p-cpe:/a:novell:opensuse:libpurple-devel, p-cpe:/a:novell:opensuse:libpurple-lang, p-cpe:/a:novell:opensuse:libpurple-meanwhile, p-cpe:/a:novell:opensuse:libpurple-mono, p-cpe:/a:novell:opensuse:libpurple-tcl, p-cpe:/a:novell:opensuse:pidgin, p-cpe:/a:novell:opensuse:pidgin-devel, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/02/19

Reference Information

CVE: CVE-2010-0013, CVE-2010-0277, CVE-2010-0420, CVE-2010-0423

CWE: 20, 22, 399