openSUSE Security Update : rubygem-actionpack (rubygem-actionpack-1946)

Medium Nessus Plugin ID 44977


The remote openSUSE host is missing a security update.


This update of rubygems fixes two vulnerabilities :

- CVE-2008-7248: CVSS v2 Base Score: 4.3 Rails CSRF protection can be bypassed by using special content-types for a HTTP request.

- CVE-2009-4214: CVSS v2 Base Score: 4.3 The method strip_tags does not completely protect against XSS attacks.


Update the affected rubygem-actionpack package.

See Also

Plugin Details

Severity: Medium

ID: 44977

File Name: suse_11_0_rubygem-actionpack-100205.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2010/03/04

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rubygem-actionpack, cpe:/o:novell:opensuse:11.0

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/02/05

Reference Information

CVE: CVE-2008-7248, CVE-2009-4214

CWE: 20, 79