SuSE 11 Security Update : gmime (SAT Patch Number 1998)

High Nessus Plugin ID 44908


The remote SuSE 11 host is missing one or more security updates.


This update of gmime fixes a buffer overflow in the GMIME_UUENCODE_LEN macro which allowed possible code execution while processing uuencoded data. (CVE-2010-0409: CVSS v2 Base Score: 5.8)


Apply SAT patch number 1998.

See Also

Plugin Details

Severity: High

ID: 44908

File Name: suse_11_gmime-100215.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2010/02/25

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:gmime, p-cpe:/a:novell:suse_linux:11:gmime-doc, p-cpe:/a:novell:suse_linux:11:gmime-sharp, p-cpe:/a:novell:suse_linux:11:libgmime-2_0-3, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2010/02/15

Reference Information

CVE: CVE-2010-0409

CWE: 119