openSUSE Security Update : gmime (gmime-1997)

High Nessus Plugin ID 44904


The remote openSUSE host is missing a security update.


This update of gmime fixes a buffer overflow in the GMIME_UUENCODE_LEN macro which allowed possible code execution while processing uuencoded data. (CVE-2010-0409: CVSS v2 Base Score: 5.8)


Update the affected gmime packages.

See Also

Plugin Details

Severity: High

ID: 44904

File Name: suse_11_2_gmime-100215.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2010/02/25

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gmime, p-cpe:/a:novell:opensuse:gmime-devel, p-cpe:/a:novell:opensuse:gmime-sharp, p-cpe:/a:novell:opensuse:libgmime-2_0-3, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2010/02/15

Reference Information

CVE: CVE-2010-0409

CWE: 119