FreeBSD : wireshark -- LWRES vulnerability (bb0a8795-15dc-11df-bf0a-002170daae37)

High Nessus Plugin ID 44429


The remote FreeBSD host is missing one or more security-related updates.


Wireshark project reports :

Babi discovered several buffer overflows in the LWRES dissector.

It may be possible to make Wireshark crash remotely or by convincing someone to read a malformed packet trace file.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 44429

File Name: freebsd_pkg_bb0a879515dc11dfbf0a002170daae37.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2010/02/10

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:wireshark, p-cpe:/a:freebsd:freebsd:wireshark-lite, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/02/10

Vulnerability Publication Date: 2010/01/27

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (Wireshark LWRES Dissector getaddrsbyname_request Buffer Overflow (loop))

Reference Information

CVE: CVE-2010-0304

Secunia: 38257

CWE: 119