openSUSE Security Update : viewvc (viewvc-1859)

High Nessus Plugin ID 44322


The remote openSUSE host is missing a security update.


The viewvc update fixes the following security problems :

- add root listing support of per-root authz config (CVE-2010-0004).

- requires 'forbidden' authorizer (or none) in config (CVE-2010-0005).


Update the affected viewvc package.

See Also

Plugin Details

Severity: High

ID: 44322

File Name: suse_11_2_viewvc-100125.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2010/01/27

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:viewvc, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2010/01/25

Reference Information

CVE: CVE-2010-0004, CVE-2010-0005

CWE: 200, 264