SuSE 11 Security Update : kdelibs4 (SAT Patch Number 1747)

Medium Nessus Plugin ID 43858

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

A KDELibs Remote Array Overrun (Arbitrary code execution) was fixed.
(CVE-2009-0689)

Solution

Apply SAT patch number 1747.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=507328

https://bugzilla.novell.com/show_bug.cgi?id=557126

http://support.novell.com/security/cve/CVE-2009-0689.html

Plugin Details

Severity: Medium

ID: 43858

File Name: suse_11_kdelibs4-100107.nasl

Version: Revision: 1.11

Type: local

Agent: unix

Published: 2010/01/12

Updated: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:kdelibs4, p-cpe:/a:novell:suse_linux:11:kdelibs4-core, p-cpe:/a:novell:suse_linux:11:libkde4, p-cpe:/a:novell:suse_linux:11:libkde4-32bit, p-cpe:/a:novell:suse_linux:11:libkdecore4, p-cpe:/a:novell:suse_linux:11:libkdecore4-32bit, p-cpe:/a:novell:suse_linux:11:utempter, p-cpe:/a:novell:suse_linux:11:utempter-32bit, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2010/01/07

Reference Information

CVE: CVE-2009-0689

CWE: 119