openSUSE Security Update : flash-player (flash-player-1707)

High Nessus Plugin ID 43381


The remote openSUSE host is missing a security update.


Specially crafted Flash (SWF) files can cause overflows in flash-player. Attackers could potentially exploit that to execute arbitrary code (CVE-2009-3794, CVE-2009-3796, CVE-2009-3797, CVE-2009-3798,CVE-2009-3799, CVE-2009-3800, CVE-2009-3951)


Update the affected flash-player package.

See Also

Plugin Details

Severity: High

ID: 43381

File Name: suse_11_1_flash-player-091216.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2009/12/22

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:flash-player, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/12/16

Reference Information

CVE: CVE-2009-3794, CVE-2009-3796, CVE-2009-3797, CVE-2009-3798, CVE-2009-3799, CVE-2009-3800, CVE-2009-3951

CWE: 94, 119, 189, 200, 399