FreeBSD : monkey -- improper input validation vulnerability (4465c897-ee5c-11de-b6ef-00215c6a37bb)

High Nessus Plugin ID 43376


The remote FreeBSD host is missing a security-related update.


Census Labs reports :

We have discovered a remotely exploitable 'improper input validation' vulnerability in the Monkey web server that allows an attacker to perform denial of service attacks by repeatedly crashing worker threads that process HTTP requests.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 43376

File Name: freebsd_pkg_4465c897ee5c11deb6ef00215c6a37bb.nasl

Version: $Revision: 1.7 $

Type: local

Published: 2009/12/22

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:monkey, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2009/12/21

Vulnerability Publication Date: 2009/12/14