PHP < 5.2.12 Multiple Vulnerabilities

Medium Nessus Plugin ID 43351

Synopsis

The remote web server uses a version of PHP that is affected by multiple flaws.

Description

According to its banner, the version of PHP installed on the remote host is older than 5.2.12. Such versions may be affected by several security issues :

- It is possible to bypass the 'safe_mode' configuration setting using 'tempnam()'. (CVE-2009-3557)

- It is possible to bypass the 'open_basedir' configuration setting using 'posix_mkfifo()'. (CVE-2009-3558)

- Provided file uploading is enabled (it is by default), an attacker can upload files using a POST request with 'multipart/form-data' content even if the target script doesn't actually support file uploads per se. By supplying a large number (15,000+) of files, an attacker could cause the web server to stop responding while it processes the file list. (CVE-2009-4017)

- Missing protection for '$_SESSION' from interrupt corruption and improved 'session.save_path' check.
(CVE-2009-4143)

- Insufficient input string validation in the 'htmlspecialchars()' function. (CVE-2009-4142)

Solution

Upgrade to PHP version 5.2.12 or later.

See Also

http://www.nessus.org/u?57f2d08f

http://www.php.net/releases/5_2_12.php

http://www.php.net/ChangeLog-5.php#5.2.12

Plugin Details

Severity: Medium

ID: 43351

File Name: php_5_2_12.nasl

Version: 1.15

Type: remote

Family: CGI abuses

Published: 2009/12/18

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2009/12/17

Vulnerability Publication Date: 2009/12/17

Reference Information

CVE: CVE-2009-3557, CVE-2009-3558, CVE-2009-4017, CVE-2009-4142, CVE-2009-4143

BID: 37389, 37390

Secunia: 37821

CWE: 79, 264