openSUSE Security Update : cups (cups-1650)

Medium Nessus Plugin ID 43107


The remote openSUSE host is missing a security update.


The cups web interface was prone to Cross-Site Scripting (XSS) problems (CVE-2009-2820).

A use-after-free problem in cupsd allowed remote attackers to crash the cups server (CVE-2009-3553).


Update the affected cups packages.

See Also

Plugin Details

Severity: Medium

ID: 43107

File Name: suse_11_2_cups-091204.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2009/12/11

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cups, p-cpe:/a:novell:opensuse:cups-client, p-cpe:/a:novell:opensuse:cups-devel, p-cpe:/a:novell:opensuse:cups-libs, p-cpe:/a:novell:opensuse:cups-libs-32bit, cpe:/o:novell:opensuse:11.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/12/04

Reference Information

CVE: CVE-2009-2820, CVE-2009-3553

CWE: 79, 399