openSUSE Security Update : wireshark (wireshark-1600)

High Nessus Plugin ID 42953


The remote openSUSE host is missing a security update.


Version upgrade of wireshark fix multiple vulnerabilities :

- CVE-2009-3549: CVSS v2 Base Score: 5.0 (MEDIUM) The Paltalk dissector could crash on alignment-sensitive processors.

- CVE-2009-3550: CVSS v2 Base Score: 4.3 (MEDIUM) The DCERPC/NT dissector could crash.

- CVE-2009-3551: CVSS v2 Base Score: 5.0 (MEDIUM) The SMB dissector could crash.

- CVE-2009-2560: CVSS v2 Base Score: 5.0 (MEDIUM) The RADIUS dissector could crash.

- CVE-2009-3829 CVSS v2 Base Score: 9.3 (HIGH) Fix for an integer overflow in wiretap/erf.c that allowed remote attackers to execute arbitrary code via a crafted ERF file. This does not affect SLE products.


Update the affected wireshark packages.

See Also

Plugin Details

Severity: High

ID: 42953

File Name: suse_11_1_wireshark-091125.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2009/12/01

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:wireshark, p-cpe:/a:novell:opensuse:wireshark-devel, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/11/25

Reference Information

CVE: CVE-2009-2560, CVE-2009-3549, CVE-2009-3550, CVE-2009-3551, CVE-2009-3829

CWE: 20, 189