openSUSE Security Update : opera (opera-1599)

Medium Nessus Plugin ID 42924


The remote openSUSE host is missing a security update.


Opera was upgraded to version 10.10 to fix the following security bugs :

- CVE-2009-0689: CVSS v2 Base Score: 6.8 A heap buffer overflow in string to number conversion.

- Error messages could leak information.

- Another, yet unspecified, vulnerability reported by Chris Evans.


Update the affected opera package.

See Also

Plugin Details

Severity: Medium

ID: 42924

File Name: suse_11_1_opera-091125.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/11/30

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:opera, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/11/25

Reference Information

CVE: CVE-2009-0689

CWE: 119