openSUSE Security Update : compat-openssl097g (compat-openssl097g-1548)

Medium Nessus Plugin ID 42838


The remote openSUSE host is missing a security update.


The TLS/SSLv3 protocol as implemented in openssl prior to this update was not able to associate data to a renegotiated connection. This allowed man-in-the-middle attackers to inject HTTP requests in a HTTPS session without being noticed. For example Apache's mod_ssl was vulnerable to this kind of attack because it uses openssl. Please note that renegotiation will be disabled by this update and may cause problems in some cases. (CVE-2009-3555: CVSS v2 Base Score: 6.4)


Update the affected compat-openssl097g packages.

See Also

Plugin Details

Severity: Medium

ID: 42838

File Name: suse_11_1_compat-openssl097g-091113.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2009/11/18

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:compat-openssl097g, p-cpe:/a:novell:opensuse:compat-openssl097g-32bit, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/11/13

Reference Information

CVE: CVE-2009-3555

CWE: 310