SuSE 11 Security Update : libopenssl (SAT Patch Number 1540)

Medium Nessus Plugin ID 42830


The remote SuSE 11 host is missing one or more security updates.


The TLS/SSLv3 protocol as implemented in openssl prior to this update was not able to associate data to a renegotiated connection. This allowed man-in-the-middle attackers to inject HTTP requests in a HTTPS session without being noticed. For example Apache's mod_ssl was vulnerable to this kind of attack because it uses openssl. Please note that renegotiation will be disabled by this update and may cause problems in some cases. (CVE-2009-3555: CVSS v2 Base Score: 6.4)


Apply SAT patch number 1540.

See Also

Plugin Details

Severity: Medium

ID: 42830

File Name: suse_11_libopenssl-devel-091112.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2009/11/17

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libopenssl0_9_8, p-cpe:/a:novell:suse_linux:11:libopenssl0_9_8-32bit, p-cpe:/a:novell:suse_linux:11:openssl, p-cpe:/a:novell:suse_linux:11:openssl-doc, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2009/11/12

Reference Information

CVE: CVE-2009-3555

CWE: 310