openSUSE 10 Security Update : cups (cups-6565)

High Nessus Plugin ID 42815


The remote openSUSE host is missing a security update.


Specially crafted PDF files could cause buffer overflows in the pdftops filter when printing such a document (CVE-2009-3608, CVE-2009-3609)


Update the affected cups packages.

Plugin Details

Severity: High

ID: 42815

File Name: suse_cups-6565.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2009/11/16

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cups, p-cpe:/a:novell:opensuse:cups-client, p-cpe:/a:novell:opensuse:cups-devel, p-cpe:/a:novell:opensuse:cups-libs, p-cpe:/a:novell:opensuse:cups-libs-32bit, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/10/14

Reference Information

CVE: CVE-2009-3608, CVE-2009-3609

CWE: 189