FreeBSD : gd -- '_gdGetColors' remote buffer overflow vulnerability (4e8344a3-ca52-11de-8ee8-00215c6a37bb)

High Nessus Plugin ID 42428


The remote FreeBSD host is missing one or more security-related updates.


CVE reports :

The _gdGetColors function in gd_gd.c in PHP 5.2.11 and 5.3.0, and the GD Graphics Library 2.x, does not properly verify a certain colorsTotal structure member, which might allow remote attackers to conduct buffer overflow or buffer over-read attacks via a crafted GD file, a different vulnerability than CVE-2009-3293.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 42428

File Name: freebsd_pkg_4e8344a3ca5211de8ee800215c6a37bb.nasl

Version: $Revision: 1.12 $

Type: local

Published: 2009/11/09

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:gd, p-cpe:/a:freebsd:freebsd:php4-gd, p-cpe:/a:freebsd:freebsd:php5-gd, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/11/05

Vulnerability Publication Date: 2009/10/15

Reference Information

CVE: CVE-2009-3546

BID: 36712

Secunia: 37069, 37080