openSUSE Security Update : xpdf (xpdf-1397)

High Nessus Plugin ID 42419


The remote openSUSE host is missing a security update.


Specially crafted PDF files could cause buffer overflows in xpdf when viewing such a document (CVE-2009-3603, CVE-2009-3604, CVE-2009-3605, CVE-2009-3606, CVE-2009-3608, CVE-2009-3609).


Update the affected xpdf packages.

See Also

Plugin Details

Severity: High

ID: 42419

File Name: suse_11_1_xpdf-091024.nasl

Version: $Revision: 1.9 $

Type: local

Agent: unix

Published: 2009/11/09

Modified: 2016/12/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:xpdf, p-cpe:/a:novell:opensuse:xpdf-tools, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/10/24

Reference Information

CVE: CVE-2009-3603, CVE-2009-3604, CVE-2009-3605, CVE-2009-3606, CVE-2009-3608, CVE-2009-3609

CWE: 189, 399