openSUSE Security Update : cyrus-imapd (cyrus-imapd-1337)

High Nessus Plugin ID 42316


The remote openSUSE host is missing a security update.


This update fixes another buffer overflow in the Sieve code (CVE-2009-3235). This can be exploited by users allowed to use their own sieve scripts to execute arbitrary code remotely. Additionally the handling of long headers was improved.


Update the affected cyrus-imapd packages.

See Also

Plugin Details

Severity: High

ID: 42316

File Name: suse_11_1_cyrus-imapd-090924.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2009/10/30

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cyrus-imapd, p-cpe:/a:novell:opensuse:cyrus-imapd-devel, p-cpe:/a:novell:opensuse:perl-Cyrus-IMAP, p-cpe:/a:novell:opensuse:perl-Cyrus-SIEVE-managesieve, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/09/24

Reference Information

CVE: CVE-2009-3235

CWE: 119