SuSE 11 Security Update : Cyrus IMAPD (SAT Patch Number 1335)

High Nessus Plugin ID 42300


The remote SuSE 11 host is missing one or more security updates.


This update fixes another buffer overflow in the Sieve code (CVE-2009-3235). This can be exploited by users allowed to use their own sieve scripts to execute arbitrary code remotely. Additionally the handling of long headers was improved.


Apply SAT patch number 1335.

See Also

Plugin Details

Severity: High

ID: 42300

File Name: suse_11_cyrus-imapd-090924.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/10/29

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:cyrus-imapd, p-cpe:/a:novell:suse_linux:11:perl-Cyrus-IMAP, p-cpe:/a:novell:suse_linux:11:perl-Cyrus-SIEVE-managesieve, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2009/09/24

Reference Information

CVE: CVE-2009-3235

CWE: 119