FreeBSD : elinks -- buffer overflow vulnerability (2544f543-c178-11de-b175-001cc0377035)

High Nessus Plugin ID 42238


The remote FreeBSD host is missing a security-related update.


SecurityFocus reports :

ELinks is prone to an off-by-one buffer-overflow vulnerability because the application fails to accurately reference the last element of a buffer.

Attackers may leverage this issue to execute arbitrary code in the context of the application. Failed attacks will cause denial-of-service conditions.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 42238

File Name: freebsd_pkg_2544f543c17811deb175001cc0377035.nasl

Version: $Revision: 1.8 $

Type: local

Published: 2009/10/26

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:elinks, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/10/25

Vulnerability Publication Date: 2006/07/29

Reference Information

CVE: CVE-2008-7224

BID: 36574

CWE: 119