openSUSE Security Update : libnewt0_52 (libnewt0_52-1331)

Medium Nessus Plugin ID 42203


The remote openSUSE host is missing a security update.


A heap-based buffer overflow was found in the way newt used to process content, to be rendered in text dialog box. Local attacker could issue a specially crafted text dialog box rendering request (direct or via custom application), leading to denial of service (application crash) or, potentially, to execution of arbitrary code with the privileges of the user running the application.

CVE-2009-2905 has been assigned to this issue.


Update the affected libnewt0_52 packages.

See Also

Plugin Details

Severity: Medium

ID: 42203

File Name: suse_11_1_libnewt0_52-090923.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2009/10/22

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libnewt0_52, p-cpe:/a:novell:opensuse:newt, p-cpe:/a:novell:opensuse:newt-devel, p-cpe:/a:novell:opensuse:newt-static, p-cpe:/a:novell:opensuse:python-newt, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/09/23

Reference Information

CVE: CVE-2009-2905

CWE: 119