openSUSE Security Update : aria2 (aria2-1400)

Critical Nessus Plugin ID 42175


The remote openSUSE host is missing a security update.


Speciall crafted distributed hash table files as used by bittorrent could cause a buffer overflow in aria2 (CVE-2009-3575).


Update the affected aria2 package.

See Also

Plugin Details

Severity: Critical

ID: 42175

File Name: suse_11_1_aria2-091014.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2009/10/19

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:aria2, cpe:/o:novell:opensuse:11.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/10/14

Reference Information

CVE: CVE-2009-3575