FreeBSD : phpmyadmin -- XSS and SQL injection vulnerabilities (4769914e-b844-11de-b159-0030843d3802)

High Nessus Plugin ID 42129


The remote FreeBSD host is missing one or more security-related updates.


phpMyAdmin Team reports :

Cross-site scripting (XSS) vulnerability allows remote attackers to inject arbitrary web script or HTML via a crafted MySQL table name.

SQL injection vulnerability allows remote attackers to inject SQL via various interface parameters of the PDF schema generator feature.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 42129

File Name: freebsd_pkg_4769914eb84411deb1590030843d3802.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2009/10/15

Modified: 2016/12/08

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:phpMyAdmin, p-cpe:/a:freebsd:freebsd:phpMyAdmin211, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2009/10/13

Vulnerability Publication Date: 2009/10/13

Reference Information

CVE: CVE-2009-3696, CVE-2009-3697

CWE: 79, 89