SuSE9 Security Update : epiphany (YOU Patch Number 12519)

high Nessus Plugin ID 42048
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SuSE 9 host is missing a security-related patch.

Description

This update brings the Mozilla SeaMonkey Suite packages to the current stable release 1.1.17.

Due to the major version update some incompatibilities might appear.

It fixes all currently published security issues, including but not limited to :

- Same-origin violations when Adobe Flash loaded via view-source: scheme. (MFSA 2009-17 / CVE-2009-1307)

- POST data sent to wrong site when saving web page with embedded frame. (MFSA 2009-21 / CVE-2009-1311)

- Crashes with evidence of memory corruption (rv:1.9.0.11). (MFSA 2009-24 / CVE-2009-1392/CVE-2009-1832 / CVE-2009-1833)

- Arbitrary domain cookie access by local file: resources.
(MFSA 2009-26 / CVE-2009-1835)

- SSL tampering via non-200 responses to proxy CONNECT requests. (MFSA 2009-27 / CVE-2009-1836)

- Arbitrary code execution using event listeners attached to an element whose owner document is null. (MFSA 2009-29 / CVE-2009-1838)

- JavaScript chrome privilege escalation. (MFSA 2009-32 / CVE-2009-1841)

- Crash viewing multipart/alternative message with text/enhanced part. (MFSA 2009-33 / CVE-2009-2210)

Solution

Apply YOU patch number 12519.

See Also

http://support.novell.com/security/cve/CVE-2009-1307.html

http://support.novell.com/security/cve/CVE-2009-1311.html

http://support.novell.com/security/cve/CVE-2009-1392.html

http://support.novell.com/security/cve/CVE-2009-1832.html

http://support.novell.com/security/cve/CVE-2009-1833.html

http://support.novell.com/security/cve/CVE-2009-1835.html

http://support.novell.com/security/cve/CVE-2009-1836.html

http://support.novell.com/security/cve/CVE-2009-1838.html

http://support.novell.com/security/cve/CVE-2009-1841.html

https://www.suse.com/security/cve/CVE-2009-2210/

Plugin Details

Severity: High

ID: 42048

File Name: suse9_12519.nasl

Version: 1.14

Type: local

Agent: unix

Published: 10/7/2009

Updated: 1/14/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 10/2/2009

Reference Information

CVE: CVE-2009-1307, CVE-2009-1311, CVE-2009-1392, CVE-2009-1832, CVE-2009-1833, CVE-2009-1835, CVE-2009-1836, CVE-2009-1838, CVE-2009-1841, CVE-2009-2210

CWE: 20, 94, 200, 287