openSUSE 10 Security Update : libsndfile (libsndfile-6277)

High Nessus Plugin ID 42017


The remote openSUSE host is missing a security update.


This update of libsndfile fixes a heap-based buffer overflow in voc_read_header() (CVE-2009-1788) and a heap-based buffer overflow in aiff_read_header() (CVE-2009-1791).


Update the affected libsndfile packages.

Plugin Details

Severity: High

ID: 42017

File Name: suse_libsndfile-6277.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2009/10/06

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsndfile, p-cpe:/a:novell:opensuse:libsndfile-32bit, p-cpe:/a:novell:opensuse:libsndfile-devel, p-cpe:/a:novell:opensuse:libsndfile-octave, p-cpe:/a:novell:opensuse:libsndfile-progs, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/05/28

Reference Information

CVE: CVE-2009-1788, CVE-2009-1791

CWE: 119