openSUSE 10 Security Update : gnutls (gnutls-6471)

High Nessus Plugin ID 42002


The remote openSUSE host is missing a security update.


This update of gnutls improves the verification of the domain/subject names in SSL certificates (CVE-2009-2730).


Update the affected gnutls packages.

Plugin Details

Severity: High

ID: 42002

File Name: suse_gnutls-6471.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2009/10/06

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gnutls, p-cpe:/a:novell:opensuse:gnutls-32bit, p-cpe:/a:novell:opensuse:gnutls-devel, p-cpe:/a:novell:opensuse:gnutls-devel-32bit, cpe:/o:novell:opensuse:10.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2009/09/01

Reference Information

CVE: CVE-2009-2730

CWE: 310